Хакеры эксплуатируют критическую RCE-уязвимость в GitLab

Специалисты компании Rapid7 предупреждают, что критическая RCE-уязвимость в GitLab, ведущая к удаленному выполнению кода без аутентификации, исправленная 14 апреля 2021 года, по-прежнему представляет опасность для 50% развертываний. Хуже того, эту проблему активно используют хакеры.

Уязвимость имеет идентификатор CVE-2021-22205  и максимально возможную оценку по шкале CVSS v3 — 10 баллов ровно. Изначально считалось, что уязвимость требует аутентификации, и ей была присвоена оценка 9,9 балла по шкале CVSS, но 21 сентября 2021 года это решение пересмотрели, когда стало ясно, что аутентификация не требуется.

Баг позволяет удаленному неаутентифицированному злоумышленнику выполнять произвольные команды от имени пользователя git (администратора репозитория). По сути, эта проблема дает атакующему полный доступ к репозиторию, включая удаление, изменение и кражу исходного кода.

Хакеры начали эксплуатировать этот баг против серверов GitLab, доступных через интернет, в июне 2021 года. Тогда ошибка применялась для создания новых пользователей и предоставления им прав администратора. Хакеры использовали в своих атаках эксплоит, опубликованный на GitHub в июне 2021 года, позволяющий им злоупотреблять уязвимым компонентом ExifTool. В рамках подобных атак злоумышленникам не нужно проходить аутентификацию, использовать токен CSRF или даже валидный эндпоинт HTTP.

Эксперты предупреждают, что эксплуатация этой проблемы продолжается до сих пор, так как, по их данным, около 50% из 60 000 развертываний GitLab, доступных через интернет, работают без патчей. При этом еще 29% установок тоже могут быть уязвимы, — аналитики не смогли определить версии этих серверов.

В Rapid7 призывают администраторов как можно скорее выполнить обновление до одной из следующих версий, чтобы исправить ошибку: 13.8.8, 13.9.6 и 13.10.3.

Источник 📢